Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Thread: Have bad lag / packetloss / lagouts? Help us fix it!

  1. #1
    give life, take death qan's Avatar
    Join Date
    Mar 2004
    Location
    oly, wa
    Posts
    750

    Have bad lag / packetloss / lagouts? Help us fix it!

    We believe we've isolated this ongoing connection problem to the network that TW is hosted on, but not the server itself. Unfortunately, the company is a large corporation that hosts over 100,000 game servers, and will not investigate the issue unless enough reports come in to make it "actionable." At that point, support agents will receive more and more negative points in their department if it isn't resolved. Simple self-interest is what will get this fixed. The information you provide will also help them locate the source of the issue. Last time this happened in 2015, it was a DDoSer using their network secretly, so we're actually doing them a big favor.


    What we need you to do: run a Trace from inside Continuum, and then submit your report to the TW server host.

    Here's how:


    1. Exit to the main menu/zone list.
    2. Select TW (or EG) and press the big TRACE button.
    3. Wait 5 (or more) minutes, or until you have at least 30-50 cycles completed. (See Cycles in bottom left corner)
    4. Click "Export..." and save the report to a text file. On your desktop is a good location, for easy reference.
    5. Open the text file from where you saved it, select all, copy, and paste into the sample letter below where it says (Paste traceroute report here)
    6. Find your IP address using www.whatismyip.com, and paste after My originating IP:
    7. Go to https://www.superb.net/about/contact-us#phonehere
    8. Fill out the form. In the Comments section, paste the completed letter.
    9. Rinse and repeat every day until they fix it. This is what worked last time.

    Technically-skilled people are encouraged to submit their own preferred multi-iteration traceroute instead of Continuum's built-in util. mtr from a Linux box is a great option, as it provides a much clearer representation of actual packetloss rates. Try this: mtr -rwc 50 -i 1.0 -rw 66.36.247.83


    Visual guide for how to use Continuum's Trace: http://imgur.com/a/BHCRt

    You can also try contacting HopOne with the same info, though when I tried a couple of days ago, the contact form was broken.
    https://www.hopone.net/contact-us/

    And, if you're willing, you're encouraged to use the Chat feature on either Superb.net or Hopone.net and explain the situation to them, and see what they are doing about the problem. (Or call them directly.) Reference Ticket #553598 and ask them what they're doing to resolve it. Every time someone reports, chats, calls, etc., this gets bumped in priority.


    -----COPY BELOW THIS LINE-----


    Hello,

    I'm a player of the game Subspace. Our game server at 66.36.247.83 has been hosted by your company for more than a decade. Many players, including me, have been experiencing extremely high packetloss, and our game server is forced to reboot several times a day as a result of it, ruining many games. The packetloss is occurring en route to the server, starting at certain entry points to Hopone, and therefore, appears unrelated to our server specifically. This has been happening for nearly a week, and is disrupting our ability to play the game. We had a similar problem in February 2015, when you discovered the cause to be a well-hidden DDoSer originating from part of your network.

    We already have a support ticket in (Ticket 553598), but our head administrator may not be available to respond to it, as the email address you have on file for him is possibly outdated. Also, it's safe to say that as one of the multi-millionaire creators of Skype and Kazaa, he's a difficult man to reach.

    Please add my traceroute report, found below, to the ticket. I will continue to submit reports to help diagnose this issue until it can be resolved.

    My originating IP: ---(Go to https://www.whatismyip.com/ and paste your IP here)---

    ---(Paste traceroute report here)---

    Thank you for your time.
    Last edited by qan; 06-24-2017 at 01:05 AM.
    "You're a gentleman," they used to say to him. "You shouldn't have gone murdering people with a hatchet; that's no occupation for a gentleman."
    -Dostoevsky's Crime and Punishment

  2. #2
    Registered User
    Join Date
    Dec 2016
    Posts
    2
    Done it today :

    Tracing Zone: SSCU Trench Wars IP Address: 66.36.247.83


    Cycles: 2535

    (Yes i send them the complete tracing file)
    Last edited by A-ss; 06-24-2017 at 01:21 AM.

  3. #3
    Registered User Jessup's Avatar
    Join Date
    Sep 2004
    Posts
    1,391
    When I first started playing.. trace would show a full long list for me and I could actually see where I was getting latency. For some reason now when I trace I get 6 Ip's listed and then in the 7 and 8 slot it shows

    7 ....

    8 ....

    with a green dot that flashes in between them.. No info is shown no matter how long I wait in these slots. When I've done Trace when I have super bad ping, the same display is shown showing no issue and the problem area remains unlisted. The 7 slots I do see show a normal connection yet my ping is 130-160 ms with s2c starting around 6.0% . When I wait in game for 30 to 40 minutes it usually slowly drops and hovers around 1.5% s2c. The ping stays high though. I notice high ping and latency tend to happen for me in the evening and when high numbers of players are in the zone. As I've said before I literally live 1 mile from our server in Washington DC.

    This was my display just now.. all seems stable and normal at this moment

    http://imgur.com/a/N1Mvz


    But this is the display when it goes haywire in evenings

    http://imgur.com/a/CTZLV


    I notice I get these cycles that seem to fluctuate daily. For me trace refuses to show the issue though.. makes me scratch my head.

    Oh also... even when ping seems normal like it is now.. the delay on pub bot is still happening where if you attach quickly to a terr in base and drop off it warps you back out into lower base where starting spawn was supposed to happen.. quite annoying heheh . Anyone have this issue too or know why the trace stops for me on 7 and 8 slot showing only ... and being totally undefined?


    This is my trace picture that shows what I mean on the 7/8 spots

    http://imgur.com/a/0IdlC
    Last edited by Jessup; 06-24-2017 at 01:33 PM.

  4. #4
    Registered User Jessup's Avatar
    Join Date
    Sep 2004
    Posts
    1,391
    Are we positive the bot lag/ double warp issues in pub are server related? My ping is 20 ms and 0.0 s2c and c2s yet the twpub is still slow to respond and warping 2 times after attaching to terrs. Could it be something else as far as the slow bot response zone has been seeing?

  5. #5
    Registered User Jessup's Avatar
    Join Date
    Sep 2004
    Posts
    1,391
    Screenshot of Evening Lag.. It just jumped up and is horrible .. was good all day until now.. ran a trace and again it will not show me where the ping is coming from

    http://imgur.com/a/66LgM

  6. #6
    Leland
    Join Date
    May 2012
    Posts
    269
    fix this lag bullshit
    Leland

  7. #7
    Administrator
    Join Date
    Jul 2016
    Posts
    72
    Please also post your traceroutes in this thread so we can update our existing support ticket with as much info as possible.

  8. #8
    Registered User
    Join Date
    Jul 2002
    Location
    Texas
    Posts
    311
    Quote Originally Posted by Wirah View Post
    Please also post your traceroutes in this thread so we can update our existing support ticket with as much info as possible.
    Mef, remember the KEY is to play from Austin, TX.... LOLS
    3x TWLD All-Star
    2x TWLD Finals MVP
    2x TWLD Champion

    TWLD Champion 'Season 11'

    TWLD Champion 'Season 14'

  9. #9
    Registered User
    Join Date
    Jul 2002
    Location
    Texas
    Posts
    311
    Name:  trace.png
Views: 270
Size:  33.9 KB
    3x TWLD All-Star
    2x TWLD Finals MVP
    2x TWLD Champion

    TWLD Champion 'Season 11'

    TWLD Champion 'Season 14'

  10. #10
    Registered User Jessup's Avatar
    Join Date
    Sep 2004
    Posts
    1,391
    So..........I know we have fairly high ping in the zone especially in the evenings (EST) but part of me is wondering about the pub issues. Why are the other bots not acting like twpubsystem with this lag? I just started elim bot and it was right on time. Zones work right on time with javduel, wbduel and base. Adds are pretty much ok on time. Sometimes a slight delay but nothing like what is going on in pub. The delay in warp is WAY more than 130 milliseconds.. it is a delay that seems like it is the 2500ms range or more. Could it possibly be an issue with the coding in twpubsystem? !help commands are even 3 seconds to respond. Something isn't adding up in my opinion with this lag issue. Call me crazy but I am starting to think the issue is in twpubsystem. Have we checked the coding recently? Has something become corrupted?

  11. #11
    give life, take death qan's Avatar
    Join Date
    Mar 2004
    Location
    oly, wa
    Posts
    750
    TW/EG/Chaos are back up but our packetloss issue remains.


    We will continue to have unplayable packetloss for some players, recycle regularly, have constant problems related to bots, etc., until this is resolved.


    I have reason to believe the comment forms on Superb.net are broken (perhaps intentionally). The one on Hopone is definitely broken. So these reports may have been going into the void. If you're angry about that, trust me, so am I.


    We need to turn up the heat on these greedy, irresponsible bastards. Here's the next step. Rather than comment forms, we're going to have to contact them directly. EDIT: Or please use this very slick form set up by Wirah!


    Go to superb.net and click Chat Now, or call 888-354-6128 (EDIT: this number may just be ad spam at certain times of the day. These guys are pro skinflints) You can also call their HQ here: 808-544-0387 Or any of these offices: 703-564-9887 571-282-6387 206-438-5887 You can also send faxes here: 808-441-0952


    Or you can also contact hopone.net at these numbers: 703-564-5400 206-438-5900 571-282-6400


    Tell them you're experiencing game-breaking packetloss to the trenchwars.org server at 66.36.247.83, hosted by Superb. Ask them what the hell they're doing about it. Don't let them go until they give you an answer. If they try to get you off the phone, give them your contact details, and tell them you expect a follow-up within 24 hours. Tell them if you don't hear back from them, you'll come back and so will a couple of your friends. In other words, they need to learn that they can't stonewall us.

    If you have a traceroute or SS trace, provide that. You can also show a report from mtr or WinMTR: http://winmtr.net You can give them your IP address with the instructions in the OP, and tell them what part of the world you're trying to reach the server from.

    If you already tried to submit an SS Trace with the comment form, please try emailing that to this address, with your location: jred@superb.net

    It's this simple: once enough people have complained, they must take action. The more people who complain, and the more often, the faster they have to resolve the issue on their network. POiD confirms this is the only way they ever got up off their butts to fix the problem last time. Of course, back then, the comment forms worked just fine. Now they wised up. So we've got to beat them at their own game and start taking it to them, where they can't squirm away.


    Don't be afraid to be rude. Have fun with it, if you want. They should know you're angry and that we're not going to stop until this gets fixed.
    Last edited by qan; 07-03-2017 at 05:22 PM.
    "You're a gentleman," they used to say to him. "You shouldn't have gone murdering people with a hatchet; that's no occupation for a gentleman."
    -Dostoevsky's Crime and Punishment

  12. #12
    Registered User Jessup's Avatar
    Join Date
    Sep 2004
    Posts
    1,391
    +100 qan

    Well said. This is unacceptable and we need to take them to task on this issue!

  13. #13
    Registered User Pressure's Avatar
    Join Date
    Feb 2005
    Posts
    1,398
    Have you called HopOne to discuss whether they can reset the server affecting the region of people who now have packetloss? This has worked time and time again in the past, even in the post-PriitK era. In the past we have just had to have PriitK email them to request the reset and they did it. Speak to M_M God about this.
    4:Best> pressure was a terr for halloween 4:Best> guy had 4 dudes on him attached

    4:Siaxis> what time is it in zimbobwe para?

    4:Children> every morning i wake up, look in the mirror and thank god i'm not paradise

    4:Best> Mighty's forehead has wifi

    4:Mighty> u guys ever eat a ketchup sandwich?

    4:sphinx> mighty fought a raccoon in an alley for some bbq chips

    4:RaCka> so what if paradise is dressing up as a slim jim for halloween?

  14. #14
    Registered User
    Join Date
    Aug 2002
    Posts
    210

  15. #15
    Registered User
    Join Date
    Nov 2011
    Posts
    34
    Can you switch hosting providers?

  16. #16
    Leland
    Join Date
    May 2012
    Posts
    269
    all superb.net employees reported
    Leland

  17. #17
    give life, take death qan's Avatar
    Join Date
    Mar 2004
    Location
    oly, wa
    Posts
    750
    Taking an unacceptably long time to resolve this, but we're still working at it. The ticket is still open. They're just avoiding us like the plague because we're a small fish that doesn't matter to them much. We have to make ourselves matter to them.


    If you're one of those who can't play...
    You might try a free VPN like WindScribe or another one listed here: http://www.techradar.com/news/the-best-free-vpn It seems counter-intuitive, but changing the location of your connection can mean it takes a different path to the server, avoiding the specific hop of gtt.net that is causing this issue.
    "You're a gentleman," they used to say to him. "You shouldn't have gone murdering people with a hatchet; that's no occupation for a gentleman."
    -Dostoevsky's Crime and Punishment

  18. #18
    give life, take death qan's Avatar
    Join Date
    Mar 2004
    Location
    oly, wa
    Posts
    750
    UPDATE: We are talking with the CEO of the company regarding this problem, and it's been identified in specific detail. They've found the source, which is with a specific piece of hardware at GTT.net, and are working to fix it.

    We should be seeing results in the next few days, so for the time being, it's no longer necessary to call in.

    Hope to have good news very soon.

    Thanks to everyone who put in their time and energy to help!
    "You're a gentleman," they used to say to him. "You shouldn't have gone murdering people with a hatchet; that's no occupation for a gentleman."
    -Dostoevsky's Crime and Punishment

  19. #19
    give life, take death qan's Avatar
    Join Date
    Mar 2004
    Location
    oly, wa
    Posts
    750
    More updates:

    Superb has informed us that GTT will be replacing faulty wiring in their hardware this Friday. We'll see if this resolves any issues.

    We are also hoping to have our bot/web server hosting provider change routing rules so that the bots take a different path to the server. This would fix some issues with slow bot responses, warping people in strange ways, etc.

    Thanks for your patience.
    "You're a gentleman," they used to say to him. "You shouldn't have gone murdering people with a hatchet; that's no occupation for a gentleman."
    -Dostoevsky's Crime and Punishment

  20. #20
    Registered User Jessup's Avatar
    Join Date
    Sep 2004
    Posts
    1,391
    Great news qan!! Fingers crossed!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •